WELCOME TO THE NEW CBRT FORUM!
Image

NO SOUND!!

This is the place to post your general tips, or need to have a question on your install here.

Moderator: JR Moderator

User avatar
timbo1
2 PILL USER
2 PILL USER
Posts: 14
Joined: Thursday, 25 June 2009, 8:21 AM
Name: tim

NO SOUND!!

Post by timbo1 » Thursday, 25 June 2009, 9:40 AM

i just hooked a new cb radio in my truck but cant get any sound even when i turn up the squelch.. any suggestions??


User avatar
Lightninrod
Duckplucker
Duckplucker
Posts: 112
Joined: Monday, 30 March 2009, 9:36 AM
Radio: RCI 2950DX
Name: dan greene
Location: Warner Robins, Georgia, CSA

Re: NO SOUND!!

Post by Lightninrod » Thursday, 25 June 2009, 9:45 AM

Not enough info to be able to offer any help :?:

You turn the squelch lower or off to hear distant signals. You don't turn it "up".
Image

"We are fast approaching the stage of the ultimate inversion: the stage where the government is free to do anything it pleases, while the citizens may act only by permission; which is the stage of the darkest periods of human history, the stage of rule by brute force."

Ayn Rand...



User avatar
Red Warrior
Donor
Donor
Posts: 791
Joined: Tuesday, 24 July 2007, 14:23 PM
Radio: Galaxy 959
Location: Santa Maria, California

Re: NO SOUND!!

Post by Red Warrior » Thursday, 25 June 2009, 9:49 AM

I can find no info on this radio so some of my advise may not be applicable.

Check for a CB/PA switch and make sure it is in the CB position.

Make sure an antenna is connected to the radio.

If you have a RF Gain control, be sure it is turned all the way up.

If the radio has USB/LSB/AM switch make sure it is on AM.

Make sure the previous owner did not leave a connector plugged into the external speaker jack.

A lot of radios will not receive without a microphone connected.
What one person receives without working for, another person must work for without receiving.



User avatar
Night Crawler
Wordwide & Qualified
Wordwide & Qualified
Posts: 3839
Joined: Tuesday, 15 May 2007, 8:03 AM
Location: Northern NJ
Referrals: 1

Re: NO SOUND!!

Post by Night Crawler » Thursday, 25 June 2009, 14:51 PM

timbo1 wrote:i just hooked a new cb radio in my truck but cant get any sound even when i turn up the squelch.. any suggestions??

If it's a new radio read the trouble shooting guide in the owners manual for suggestions for what could be wrong.

User avatar
TheCBDoctor
Sponsor
Sponsor
Posts: 2811
Joined: Friday, 13 March 2009, 13:54 PM
Radio: HR 2510
Name: Rick
Referrals: 4
Contact:

Re: NO SOUND!!

Post by TheCBDoctor » Thursday, 25 June 2009, 20:18 PM

Hi timbo1

Plug an external speaker into the jack in the back. If you still get no sound, then plug it into the PA jack and put the radio into the PA mode. If you hear noise, then the receive wire on the Mic is bad. If the radio was ever hooked up backwards and the polarity protector is open, then the audio chip is popped. Sometimes the tab on the external speaker jack is not making contact due to wear. This will keep the internal speaker from working.

Good luck,
Best Regards,

Rick, The CB Doctor


OFFICIAL SPONSOR - http://www.thecbdoctor.net/" onclick="window.open(this.href);return false;
Image




User avatar
timbo1
2 PILL USER
2 PILL USER
Posts: 14
Joined: Thursday, 25 June 2009, 8:21 AM
Name: tim

Re: NO SOUND!!

Post by timbo1 » Friday, 26 June 2009, 17:43 PM

just wanted to give you an update. i tried what you suggested and still nothing happend. i also tried 4 more differnt antennas and that didnt work either. i have another question. i didnt have anywhere good to mount my cb so i mounted it on the center consol in my truck, ive been wondering if i needed to mount it somewhere where its better grounded, maybe this is the problem. also does my antenna need to be grounded?

User avatar
Mikey B
Donor
Donor
Posts: 477
Joined: Monday, 09 March 2009, 15:57 PM
Radio: Cobra 29 WX NW ST
Name: -B-
Location: The Pine Tree

Re: NO SOUND!!

Post by Mikey B » Friday, 26 June 2009, 17:45 PM

A magnet mount antenna uses the metal surface that the mag sits on for a ground plane. It does this through capacitance.
"We have room for but one flag, the American Flag. We have room for but one language, the English language, and we have room for but one sole loyalty, and that is a loyalty to the American people. " - - Pres. Theodore Roosevelt.
KB1TBF
"B-DOG"




Post Reply Previous topicNext topic

Who is online

Users browsing this forum: No registered users and 1 guest