Image

Need Help

Microphone Information Wiring etc, or if you just need help with choosing a good microphone for your radio.

Moderator: JR Moderator

User avatar
EasyMoney66
NEW DUCK
NEW DUCK
Posts: 3
Joined: Tuesday, 19 April 2016, 20:55 PM

Need Help

Post by EasyMoney66 » Tuesday, 19 April 2016, 21:33 PM

I've got a galaxy 66 that has been working fine lately but I had it out of my truck & when I hooked it back up & plugged the mic in it started smoking the mic wires. Does anybody have any suggestions on what could have caused that? Any help would be great. Thanks


User avatar
sonoma
Donor
Donor
Posts: 1352
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Need Help

Post by sonoma » Wednesday, 20 April 2016, 8:04 AM

could be the mic socket turned just enough when you put the mic on the radio to short a diode. think it is D77 that is easy to short if the mic socket gets loose and turns just a little.. hope that is what happened to you if you are luccky.

User avatar
MDYoungblood
Moderator
Moderator
Posts: 7411
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPad
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD
Contact:

Re: Need Help

Post by MDYoungblood » Wednesday, 20 April 2016, 10:11 AM

Hello EasyMoney66,
Welcome to the forum. This is a new one on me, unless something inside the came loose and touched a 8v source that shouldn't have happened. does the radio have any toys installed or possibly a power mic?
As a new member could you post a intro in the "Welcome to the Forum" topic, viewforum.php?f=89" onclick="window.open(this.href);return false; , so others can say "Hi", thanks.

3's

Greg
"321, the Middle of Maryland"

23 AM "WORLD WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment



Official Moderator - CBRT Complaint Department



User avatar
sonoma
Donor
Donor
Posts: 1352
Joined: Sunday, 02 April 2006, 14:10 PM
Location: Oklahoma

Re: Need Help

Post by sonoma » Wednesday, 20 April 2016, 10:23 AM

I just looked at a pic of the main board and it is D77 that is right by the mic socket. if you look at the pic I am leaving you it will be in the lower right corner of the picture. when you tighten the mic plug up it can gett into D77 and cause a short. may or may not be the problem you will just have to pull the cover and verify the parts touching.

http://www.cbtricks.com/radios/galaxy/d ... 4b_top.gif" onclick="window.open(this.href);return false;

User avatar
MDYoungblood
Moderator
Moderator
Posts: 7411
Joined: Saturday, 12 June 2010, 19:05 PM
Logged in via: iPad
Radio: Uniden Washington
Antenna: Avanti Sigma II
Name: Greg
Location: Baltimore, MD
Contact:

Re: Need Help

Post by MDYoungblood » Wednesday, 20 April 2016, 11:53 AM

I'm more incline to think it might be the echo board gone bad, there is more than enough voltage there to smoke the mic wires, open it up and see what's caused it.

3's

Greg
"321, the Middle of Maryland"

23 AM "WORLD WIDE" 38 LSB

Strong Supporter of America's Original Homeland Security Act
The Second Amendment



Official Moderator - CBRT Complaint Department




User avatar
EasyMoney66
NEW DUCK
NEW DUCK
Posts: 3
Joined: Tuesday, 19 April 2016, 20:55 PM

Re: Need Help

Post by EasyMoney66 » Wednesday, 20 April 2016, 12:38 PM

Thanks for the info I'll definitely check it out. Looks like I came to the right place.


Post Reply Previous topicNext topic

Who is online

Users browsing this forum: Majestic-12 [Bot] and 3 guests